$re = '/\}? +and +(?![^{]*\})\{?/';
$str = 'Max and Bob and Merry and {Jack and Co.} and Lisa';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);