use strict;
my $str = 'bar("string"",bar($str,CONST,func($s,o))) //1
bar("string\\",bar($str,CONST,func($s,o))) //2
bar("",bar($str,CONST,func($s,o))) //This regex is supported, but when I try to be compatible with both cases, the problem occurs';
my $regex = qr/(?<CV>\$*\w++\s*)\s*\((\s*(?<PRM>(\g<0>)|(?<STRING>"(?:[^"\\]*(?:\\.[^"\\]*)*)"|'(?:[^'\\]*(?:\\.[^'\\]*)*)')|(\g<CV>))\s*(,\s*(\g<PRM>))*)?+\s*\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}