$re = '/(?<CV>\$*\w++\s*)\s*\((\s*(?<PRM>(\g<0>)|(?<STRING>"(?:[^"\\\\]*(?:\\\\.[^"\\\\]*)*)"|\'(?:[^\'\\\\]*(?:\\\\.[^\'\\\\]*)*)\')|(\g<CV>))\s*(,\s*(\g<PRM>))*)?+\s*\)/m';
$str = 'bar("string"",bar($str,CONST,func($s,o))) //1
bar("string\\",bar($str,CONST,func($s,o))) //2
bar("",bar($str,CONST,func($s,o))) //This regex is supported, but when I try to be compatible with both cases, the problem occurs';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);