import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9A-Za-z_\\.-]+)@([]0-9A-Za-z_\\-]+)\\.([a-z]{2,9})";
final String string = "a@b.com\n"
+ "a@b.cz\n"
+ "a@b.org\n"
+ "a@b.pl\n"
+ "fredy.crueger@elm-street.com\n"
+ "fredy_crueger@elm-street.com\n"
+ "fredy-crueger@elm-street.com\n"
+ "fredy.crueger@.elm-street.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}