#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\S\n]*(\w+(?: +\w+)*?)(?=:| joined the lobby$)"
Local $sString = "Hey Guys," & @CRLF & _
"" & @CRLF & _
"I want to filter the usernames out of the following string from a game lobby:" & @CRLF & _
"" & @CRLF & _
" Username123 joined the lobby" & @CRLF & _
"" & @CRLF & _
" User name 123 joined the lobby" & @CRLF & _
"" & @CRLF & _
" Otheruser 12 joined the lobby" & @CRLF & _
"" & @CRLF & _
" Username123: Hello Guys!" & @CRLF & _
"" & @CRLF & _
" o t h e ruser23 joined the lobby" & @CRLF & _
"" & @CRLF & _
" Player1 3 joined the lobby" & @CRLF & _
"" & @CRLF & _
"As you can see, the username can consist of characters, numbers and spaces. Before every Username a new line starts and the "joined the lobby" part is fixed. However between 2 users joining an already joined user can write a textmessage to the whole lobby." & @CRLF & _
"" & @CRLF & _
"How can I extract the 5 unique usernames?" & @CRLF & _
"" & @CRLF & _
" I joined the lobby" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")