import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\S\\n]*(\\w+(?: +\\w+)*?)(?=:| joined the lobby$)";
final String string = "Hey Guys,\n\n"
+ "I want to filter the usernames out of the following string from a game lobby:\n\n"
+ " Username123 joined the lobby\n\n"
+ " User name 123 joined the lobby\n\n"
+ " Otheruser 12 joined the lobby\n\n"
+ " Username123: Hello Guys!\n\n"
+ " o t h e ruser23 joined the lobby\n\n"
+ " Player1 3 joined the lobby\n\n"
+ "As you can see, the username can consist of characters, numbers and spaces. Before every Username a new line starts and the \"joined the lobby\" part is fixed. However between 2 users joining an already joined user can write a textmessage to the whole lobby.\n\n"
+ "How can I extract the 5 unique usernames?\n\n"
+ " I joined the lobby\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}