package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[MSG:(.*?)\]`)
var str = `[ABCD:defg] [MSG:information] [MSG2:hello]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}