$re = '/\[MSG:(.*?)\]/m';
$str = '[ABCD:defg] [MSG:information] [MSG2:hello]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);