package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+:\D{8}\d{2}`)
var str = `1:nlcbjduy14 <- I want regex to find this one
2:Peoples123 <- I don't want regex to find this one, as it has 3 digits.
3:sqourzyr17 <- I want regex to find this one
4:rdmaszgr94 <- I want regex to find this one
5:tnwiudic22 <- I want regex to find this one
6:zfcxmkrs21 <- I want regex to find this one
7:xrwhsgno55 <- I want regex to find this one
8:modtwtrr06 <- I want regex to find this one
9:People123 <- I don't want regex to find this one, as it is isn't 10 chars long and it consists of 3 digits.
10:aetmyqqh52 <- I want regex to find this one
11:Howtocodelikeapro12 <- I don't want regex to find this one, as it is isn't 10 chars long
12:netphvib58 <- I want regex to find this one
13:uwyiqhoj29 <- I want regex to find this one
14:RegexJustiIsntDoingItForMe
15:qyeiaecj27 <- I want regex to find this one
16:buttercake <- I don't want regex to find this one, as it doesn't end with 2 digits.
17:bcyiyjdm23 <- I want regex to find this one
18:Differings <- I don't want regex to find this one, as it doesn't end with 2 digits.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}