#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^(?!(?:\w*(.)\1){3}).+$)(?=^(?:(.)(?!(?:.*?\2){4}))*$)"
Local $sString = "adminnisstrator21" & @CRLF & _
"kkeeykloakk" & @CRLF & _
"stack22ooverflow" & @CRLF & _
"blahbllahhblaafaa" & @CRLF & _
"" & @CRLF & _
"test$$$$test" & @CRLF & _
"test$$$$$test" & @CRLF & _
"testttest" & @CRLF & _
"adcdddd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")