$re = '/(?=^(?!(?:\w*(.)\1){3}).+$)(?=^(?:(.)(?!(?:.*?\2){4}))*$)/m';
$str = 'adminnisstrator21
kkeeykloakk
stack22ooverflow
blahbllahhblaafaa
test$$$$test
test$$$$$test
testttest
adcdddd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);