using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ALM\d+_.{3}(?(?<=BIT)(_\d*||[^\d]\S*)|.*)$";
string input = @"COM-ALM2_BIT_1
COM-ALM2_BIT
COM-ALM2_AZIrgendwas_1
COM-ALM3_NameBIT
COM-ALM3_BITName
COM-ALM3_Name
COM-ALM3_BITName12
match.Success == false
COM-ALM2_BIT1
COM-ALM2_BIT15
COM-ALM11_BIT7
COM-ALM11_BIT11
OM-ALM_BIT1
COM-ALM_Name
(?(bit)(_d+)|(.*))
ALM\d+_(BIT(_\d+|[^\d]*))$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}