import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "ALM\\d+_.{3}(?(?<=BIT)(_\\d*||[^\\d]\\S*)|.*)$";
final String string = "COM-ALM2_BIT_1\n"
+ "COM-ALM2_BIT\n"
+ "COM-ALM2_AZIrgendwas_1\n"
+ "COM-ALM3_NameBIT\n"
+ "COM-ALM3_BITName\n"
+ "COM-ALM3_Name\n"
+ "COM-ALM3_BITName12\n\n"
+ "match.Success == false\n"
+ "COM-ALM2_BIT1\n"
+ "COM-ALM2_BIT15\n"
+ "COM-ALM11_BIT7\n"
+ "COM-ALM11_BIT11\n"
+ "OM-ALM_BIT1\n"
+ "COM-ALM_Name\n\n"
+ "(?(bit)(_d+)|(.*))\n"
+ "ALM\\d+_(BIT(_\\d+|[^\\d]*))$";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}