package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bproduct\s+(.*?)\s+cat[12]\b`)
var str = `product product name cat1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}