$re = '/\bproduct\s+(.*?)\s+cat[12]\b/m';
$str = 'product product name cat1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);