package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\d+>: (\w+): %([\w-]+): ([^\n]+)`)
var str = `<189>: sample_username: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/1, changed state to down
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}