re = /<\d+>: (\w+): %([\w-]+): ([^\n]+)/m
str = '<189>: sample_username: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet2/0/1, changed state to down
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end