#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=(?:.*[A-Z]){2})(?=(?:.*[0-9]){3})(?:([a-zA-Z0-9])(?!.*\1)){10}$"
Local $sString = "AB12345678" & @CRLF & _
"ABC1234567" & @CRLF & _
"1A23B456C7" & @CRLF & _
"ABcde12345" & @CRLF & _
"1234567890" & @CRLF & _
"A123456789" & @CRLF & _
"ABC123456A" & @CRLF & _
"ABC123456" & @CRLF & _
"ABC12345678"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")