re = /^(?=(?:.*[A-Z]){2})(?=(?:.*[0-9]){3})(?:([a-zA-Z0-9])(?!.*\1)){10}$/m
str = 'AB12345678
ABC1234567
1A23B456C7
ABcde12345
1234567890
A123456789
ABC123456A
ABC123456
ABC12345678'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end