using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=(?![0-9])).+$";
string input = @"00067802:ygavet, tankt::math:ND
56710982:saturn; *Ustaris:fgK
Alexis:4D; %*BIOL
dadad:43414214
1daada
0d1d2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}