$re = '/(<h4\b[^>]*>(.*?)<\/h4>)[\s]?(<ul\b[^>]*>(.*?)<\/ul>)/';
$str = '<h4>Плюсы</h4><ul> <li>Доступная цена.</li> <li>Есть во многих магазинах.</li> <li>Практичный дизайн.</li> <li>Хорошо удаляет волосы.</li> <li>Хватает на несколько процедур.</li> <li>В комплект входит 5 бритв.</li> <li>Острые лезвия.</li></ul> <h4>Минусы</h4>Не справляется с жесткой щетиной.<h3>Arko Men System3</h3блабалб бал бла бла бла <h4>Плюсы</h4><ul> <li>Недорогие.</li> <li>Некоторые пользователи применяют их для нескольких процедур. При этом лезвия сохраняют свою остроту.</li> <li>Не вызывают раздражение.</li> <li>Плавающая головка.</li> <li>Низкая стоимость.</li> <li>В набор входит 4 станка.</li></ul> <h4>Минусы</h4> <ul><li>Плавающая головка.</li> <li>Низкая стоимость.</li> <li>В набор входит 4 станка.</li> </ul>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);