// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<h4\b[^>]*>(.*?)<\/h4>)[\s]?(<ul\b[^>]*>(.*?)<\/ul>)").unwrap();
let string = "<h4>Плюсы</h4><ul> <li>Доступная цена.</li> <li>Есть во многих магазинах.</li> <li>Практичный дизайн.</li> <li>Хорошо удаляет волосы.</li> <li>Хватает на несколько процедур.</li> <li>В комплект входит 5 бритв.</li> <li>Острые лезвия.</li></ul> <h4>Минусы</h4>Не справляется с жесткой щетиной.<h3>Arko Men System3</h3блабалб бал бла бла бла <h4>Плюсы</h4><ul> <li>Недорогие.</li> <li>Некоторые пользователи применяют их для нескольких процедур. При этом лезвия сохраняют свою остроту.</li> <li>Не вызывают раздражение.</li> <li>Плавающая головка.</li> <li>Низкая стоимость.</li> <li>В набор входит 4 станка.</li></ul> <h4>Минусы</h4> <ul><li>Плавающая головка.</li> <li>Низкая стоимость.</li> <li>В набор входит 4 станка.</li> </ul>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}