$re = '/\b[A-Z][a-z]*\b/m';
$str = 'Meet Kara Denvers and Barry Allen.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);