import re
regex = re.compile(r"^([a-z]+)(?:([A-Z]{1})([a-z]+))+$", flags=re.MULTILINE)
test_str = ("myjfgfgffhVarBaThisVinoth\n"
"myVar\n"
"MYVAR\n"
"my-var\n"
"my.var\n"
"Myvar\n"
"My var\n"
"my var\n"
"Myvar\n"
"myvar\n"
"my Var\n"
"myVar \n"
"myVAR\n"
"myVARandV\n"
"my_var\n"
"myVarAndV\n"
"myAndVar\n"
"myV_ar\n"
"my_Var\n"
"my*Var\n"
"myV*ar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")