re = /\b(?<!\$|->)\w+\[]/m
str = '/** @var string[] */
/** @return string[] */
* @param Company[]|null $companies
$icons[] = static::getIconDetailsFromLink($link);
$this->properties[] = $property;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end