using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^P((\d+([,\.]\d+)?Y)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?D)?(T(\d+([,\.]\d+)?H)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?S)?)?$)|(\d+([,\.]\d+)?W$)";
string input = @"P1Y
PT35M
P0.5Y
P4W";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}