const regex = /^P((\d+([,\.]\d+)?Y)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?D)?(T(\d+([,\.]\d+)?H)?(\d+([,\.]\d+)?M)?(\d+([,\.]\d+)?S)?)?$)|(\d+([,\.]\d+)?W$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^P((\\d+([,\\.]\\d+)?Y)?(\\d+([,\\.]\\d+)?M)?(\\d+([,\\.]\\d+)?D)?(T(\\d+([,\\.]\\d+)?H)?(\\d+([,\\.]\\d+)?M)?(\\d+([,\\.]\\d+)?S)?)?$)|(\\d+([,\\.]\\d+)?W$)', 'gm')
const str = `P1Y
PT35M
P0.5Y
P4W`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}