#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:.*?^0\,){1}"
Local $sString = ""REC01"," & @CRLF & _
""Recipe1"," & @CRLF & _
"10," & @CRLF & _
"""," & @CRLF & _
"""," & @CRLF & _
"" "," & @CRLF & _
"2000," & @CRLF & _
""0101"," & @CRLF & _
"" "," & @CRLF & _
"" "," & @CRLF & _
""126"," & @CRLF & _
""REC01"," & @CRLF & _
"" "," & @CRLF & _
"0," & @CRLF & _
"0," & @CRLF & _
"5," & @CRLF & _
"38.182,"11200","Ingredient1"," "," ","1"," & @CRLF & _
"12.121,"11800","Ingredient2"," "," ","1"," & @CRLF & _
"27.475,"30910","Ingredient3"," "," ","1"," & @CRLF & _
"2.020,"26200","Ingredient4"," "," ","1"," & @CRLF & _
"20.202,"C01","Ingredient5"," "," ","1"," & @CRLF & _
"0," & @CRLF & _
""REC02"," & @CRLF & _
""Recipe2"," & @CRLF & _
"10," & @CRLF & _
""13/04/21"," & @CRLF & _
""13/04/21"," & @CRLF & _
"" "," & @CRLF & _
"1000," & @CRLF & _
""0101"," & @CRLF & _
"" "," & @CRLF & _
"" "," & @CRLF & _
""17"," & @CRLF & _
""REC02"," & @CRLF & _
"" "," & @CRLF & _
"0," & @CRLF & _
"0," & @CRLF & _
"3," & @CRLF & _
"61.600,"11200","Ingredient1"," "," ","1"," & @CRLF & _
"23.400,"30910","Ingredient3"," "," ","1"," & @CRLF & _
"15.000,"BR-F01","Ingredient6"," "," ","1"," & @CRLF & _
"0," & @CRLF & _
""REC03"," & @CRLF & _
""Recipe3"," & @CRLF & _
"10," & @CRLF & _
""19/03/21"," & @CRLF & _
""19/03/21"," & @CRLF & _
"" "," & @CRLF & _
"1000," & @CRLF & _
""0103"," & @CRLF & _
"" "," & @CRLF & _
"" "," & @CRLF & _
""28"," & @CRLF & _
""REC03"," & @CRLF & _
"" "," & @CRLF & _
"0," & @CRLF & _
"0," & @CRLF & _
"9," & @CRLF & _
"64.450,"11200","Ingredient1"," "," ","1"," & @CRLF & _
"12.700,"30910","Ingredient3"," "," ","1"," & @CRLF & _
"2.000,"20600","Ingredient7"," "," ","1"," & @CRLF & _
"12.000,"27220","Ingredient8"," "," ","1"," & @CRLF & _
"0.320,"584","Ingredient9"," "," ","1"," & @CRLF & _
"0.830,"588","Ingredient10"," "," ","1"," & @CRLF & _
"0.050,"599","Ingredient11"," "," ","1"," & @CRLF & _
"0.040,"600","Ingredient12"," "," ","1"," & @CRLF & _
"7.610,"585","Ingredient13"," "," ","1"," & @CRLF & _
"0,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")