#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([A-Za-z]+\d*(?: [A-Za-z]+\d*)+) \d+-\d+$"
Local $sString = "Hyderabad RTC K1 1991-1998" & @CRLF & _
"Hyderabad RTC KK 1876-1897" & @CRLF & _
"Al Test K5 1876-9876"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")