$re = '/^([A-Za-z]+\d*(?: [A-Za-z]+\d*)+) \d+-\d+$/mi';
$str = 'Hyderabad RTC K1 1991-1998
Hyderabad RTC KK 1876-1897
Al Test K5 1876-9876';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);