# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^|\/)[[:alpha:]]*[[:digit:]][[:alnum:]]*(?![^\n\/])/\1my_var\2/gm;t' <<< "/example/endpoint/here/34456dwf45
/endpoint/fddk449372
/434236/example/endpoint"