use strict;
my $str = '/text1/text2/text3/wanted_text/text5/text6';
my $regex = qr%(/[^/]+){3}/([^/]+).*%mp;
my $subst = '\\2';
my $result = $str =~ s%$regex%$subst%rg;
print "The result of the substitution is' $result\n";