$re = '%(/[^/]+){3}/([^/]+).*%m';
$str = '/text1/text2/text3/wanted_text/text5/text6';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;