package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bCUI:\s+\S+\s+\S+\s+(\S+)`)
var str = `CUI: RO39890982 BZ 347`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}