$re = '/\bCUI:\s+\S+\s+\S+\s+(\S+)/m';
$str = 'CUI: RO39890982 BZ 347';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);