using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(?=(,|:).*?~.*?~.*?\1_(.))|#|,|:.*";
string substitution = @"$3";
string input = @"#1,0110,0010:~;0101_1000;0110_1001;0111_1010;1000_1011;1001_1100;1010_1101;1011_1110;1100_1111,~0000_00001_10010_20011_30100_40101_50110_60111_71000_81001_9";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}