re = /(\d+)(?=(,|:).*?~.*?~.*?\1_(.))|#|,|:.*/
str = '#1,0110,0010:~;0101_1000;0110_1001;0111_1010;1000_1011;1001_1100;1010_1101;1011_1110;1100_1111,~0000_00001_10010_20011_30100_40101_50110_60111_71000_81001_9'
subst = '$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result