using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=@)[a-zA-Z]+(?=[^:]*:\d+![AD]!)";
string input = @"PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}