$re = '/(?<=@)[a-zA-Z]+(?=[^:]*:\d+![AD]!)/m';
$str = 'PQ@Alderaa1:30000!A!->20000
@Cantonica:3000!D!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);