$re = '~<span>
[^<>]*+
(?>
[^<>]+
| (?!<span>|</span>).
| (?R)
)*
</span>~sxiX';
$str = 'Начало.
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span></span>.
ошибка
<span>правильно</span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
ошибка
Конец.';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;