# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
<span>
[^<>]*+
(?>
[^<>]+
| (?!<span>|</span>).
| (?R)
)*
</span>
"""
test_str = ("Начало.\n"
"<span><b>правильно</b></span>\n"
"ошибка\n"
"<span>правильно <i><span>правильно</span></i> правильно</span>.\n"
"ошибка\n"
"<i><span>правильно <span><i>правильно</i></span> правильно</span></span>.\n"
"ошибка\n"
"<span>правильно</span>\n"
"ошибка\n"
"<span></span>\n"
"ошибка\n"
"<span><span></span></span>\n"
"ошибка\n"
"<span>ошибка<span>ошибка<span>правильно</span>\n"
"ошибка\n"
"Конец.")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL | re.VERBOSE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.