using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<span>
[^<]*+ #speed improves
(?>
[^<]+
| (?!<span>|</span>).
| (?R)
)*+
</span>";
string input = @"Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}