$re = '~<span>
[^<]*+ #speed improves
(?>
[^<]+
| (?!<span>|</span>).
| (?R)
)*+
</span>~sxiX';
$str = 'Начало.
<spar>ошибка</spar>
<span><b>правильно</b></span>
ошибка
<span>правильно <i><span>правильно</span></i> правильно</span>.
ошибка
<i><span>правильно <span><i>правильно</i></span> правильно</span><spar>ошибка</spar></span>.
ошибка
<span><spar>правильно</spar></span>
ошибка
<span></span>
ошибка
<span><span></span></span>
ошибка
<span>ошибка<span>ошибка<span>правильно</span>
<span>ошибка<span>
Конец.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);