package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<div id="myScreen"[\s\S]*?<\/div>\s*<\/form>`)
var str = `<!DOCTYPE html>
<html class="no-js" lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="x-ua-compatible" content="ie=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="stylesheet" href="assets/css/app.css"></link>
<title>App Android</title>
</head>
<form action="#" class="formulario" name="formulario">
<style>
.campo-texto {
color: #7B7D7D;
height: 30px;
position: absolute;
padding: 0px 5px 0px 5px;
border-style: ridge;
resize: horizontal;
overflow-x: hidden;
overflow-y: hidden;
background-color: white;
text-align: left;
border-radius: 6px;
}
.campo-botao {
position: absolute;
height: 28px;
width: 80px;
border: 2px solid rgba(0, 0, 0, 0.3);
text-align: center;
border-radius: 6px;
box-shadow: 2px 2px 2px #888;
overflow: hidden;
}
.campo-prompt {
position: absolute;
min-height: 20px;
display: inline-block;
padding: 0px 5px 0px 5px;
border: 1px dotted black;
border-radius: 6px;
}
.a9-screen-dimension {
position: relative;
margin: 0px;
width: 340px;
height: 540px;
border: 1px solid black;
background-color: #CED7E5;
overflow: hidden;
}
</style>
<body>
<div id="myScreen" class="a9-screen-dimension" tabindex="0">
<div id="promptId0" class="campo-prompt" draggable="true" style="top:68.625px; left:65.84375px;" tabindex="0">Prompt</div><button id="botaoId1" class="campo-botao" draggable="true" style="top:235.625px; left:77.84375px;" tabindex="0" myselection="salvar">Salvar</div></div>
</div>
</form>
<script>
function send(toast) {
var cod = formulario.cod.value;
Android.sendDataToAndroid(cod);
}
</script>
</body>
</html>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}