import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div id=\"myScreen\"[\\s\\S]*?<\\/div>\\s*<\\/form>";
final String string = "<!DOCTYPE html>\n"
+ "<html class=\"no-js\" lang=\"en\">\n"
+ "<head>\n"
+ "<meta charset=\"utf-8\">\n"
+ "<meta http-equiv=\"x-ua-compatible\" content=\"ie=edge\">\n"
+ "<meta name=\"viewport\" content=\"width=device-width, initial-scale=1.0\">\n"
+ "<link rel=\"stylesheet\" href=\"assets/css/app.css\"></link>\n"
+ "<title>App Android</title>\n"
+ "</head>\n"
+ "<form action=\"#\" class=\"formulario\" name=\"formulario\">\n"
+ "<style>\n"
+ " .campo-texto {\n"
+ " color: #7B7D7D;\n"
+ " height: 30px;\n"
+ " position: absolute;\n"
+ " padding: 0px 5px 0px 5px;\n"
+ " border-style: ridge;\n"
+ " resize: horizontal;\n"
+ " overflow-x: hidden;\n"
+ " overflow-y: hidden;\n"
+ " background-color: white;\n"
+ " text-align: left;\n"
+ " border-radius: 6px;\n"
+ " }\n"
+ " .campo-botao {\n"
+ " position: absolute;\n"
+ " height: 28px;\n"
+ " width: 80px;\n"
+ " border: 2px solid rgba(0, 0, 0, 0.3);\n"
+ " text-align: center;\n"
+ " border-radius: 6px;\n"
+ " box-shadow: 2px 2px 2px #888;\n"
+ " overflow: hidden;\n"
+ " }\n"
+ " .campo-prompt {\n"
+ " position: absolute;\n"
+ " min-height: 20px;\n"
+ " display: inline-block;\n"
+ " padding: 0px 5px 0px 5px;\n"
+ " border: 1px dotted black;\n"
+ " border-radius: 6px;\n"
+ " }\n"
+ " .a9-screen-dimension {\n"
+ " position: relative;\n"
+ " margin: 0px;\n"
+ " width: 340px;\n"
+ " height: 540px;\n"
+ " border: 1px solid black;\n"
+ " background-color: #CED7E5;\n"
+ " overflow: hidden;\n"
+ " }\n"
+ "</style>\n"
+ "<body>\n"
+ "<div id=\"myScreen\" class=\"a9-screen-dimension\" tabindex=\"0\"> \n"
+ " <div id=\"promptId0\" class=\"campo-prompt\" draggable=\"true\" style=\"top:68.625px; left:65.84375px;\" tabindex=\"0\">Prompt</div><button id=\"botaoId1\" class=\"campo-botao\" draggable=\"true\" style=\"top:235.625px; left:77.84375px;\" tabindex=\"0\" myselection=\"salvar\">Salvar</div></div>\n"
+ "</div>\n"
+ "</form>\n"
+ "<script>\n"
+ "function send(toast) {\n"
+ " var cod = formulario.cod.value;\n"
+ " Android.sendDataToAndroid(cod);\n"
+ "}\n"
+ "</script>\n"
+ "</body>\n"
+ "</html>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}