#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^[a-z0-9](?=[a-z0-9 ]{0,49}$)(?=([a-z0-9]+(?: [a-z0-9]+)*))\1$"
Local $sString = "abcdefghij abcdefghij abcdefghij abcdefghij abcdef " & @CRLF & _
"abcdefghij abcdefghij abcdefghij abcdefghij abcdef" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljlj " & @CRLF & _
"" & @CRLF & _
"ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4&" & @CRLF & _
"" & @CRLF & _
"ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4" & @CRLF & _
"" & @CRLF & _
"@$%" & @CRLF & _
"" & @CRLF & _
"@$% #$%" & @CRLF & _
"a @#$% 2" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")