re = /^[a-z0-9](?=[a-z0-9 ]{0,49}$)(?=([a-z0-9]+(?: [a-z0-9]+)*))\1$/mi
str = 'abcdefghij abcdefghij abcdefghij abcdefghij abcdef
abcdefghij abcdefghij abcdefghij abcdefghij abcdef
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljljghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4 j kljlkjkljkljlk lkjlk j lk jkjlkjklljlj
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4&
ghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjghgffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffkljlkjh4
@$%
@$% #$%
a @#$% 2
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end