package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\w\s]+)\s+[\u2192]\s+([\w\s;:]+)`)
var str = `brow fox → jumps over the lazy dog`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}