// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]+)(\s)?\/(\s)?(([0-9\/]+))").unwrap();
let string = " + 25/50/75/100/125/150/175 ед.
+ 25 /50/75/100/125 /150/ 175 ед.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}