const regex = /(([0][1-9]|[1][0-2]):([0-5][0-9])([p][m]))|(([0][0-9]|[1][01]):([0-5][0-9])([a][m]))/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([0][1-9]|[1][0-2]):([0-5][0-9])([p][m]))|(([0][0-9]|[1][01]):([0-5][0-9])([a][m]))', '')
const str = `00:59am`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}